
Part II:  Using the Drug Court


Case Management System 2000 

System Requirements

  You will need Windows 95 or higher and          Access 97 or higher to run the CMS. Your        computer should have at least 32K of RAM       and a mouse. The capacity of the CMS is           limited only by the capacity of your own hard    disk and back-up device.

Overview
The Drug Court Case Management System 2000 (CMS) is a simple, menu-driven system developed primarily for use by small drug courts. On-screen forms mimic those typically used to record information on drug court clients from intake through to their termination or graduation.  Paper forms are also attached (and included on the compact disk), giving you the option of entering data directly into the CMS from the start or capturing information on paper forms and entering it into the CMS at a later date.

The CMS contains built-in reports to summarize and print case file information.  Four individual progress reports may be produced.  The Case Summary Report presents information on a participant’s current status, outcomes and points earned at each drug court date, and total points to date.  The other three individual reports summarize a participant’s 12-Step Progress, Urinalysis Results, and Payments to date.

Lists of participants may be displayed and printed, sorted alphabetically or by admission date.  These lists include name, address, and phone numbers.

The CMS also produces Snapshot Reports, which present summary information for the present month on the number of new cases, number of terminations and graduations, number of participants in each phase, the status of current cases, and the number of cases in various types of treatment.  Because this information changes from day to day, the caseload report is a snapshot in time and can be produced only for the current month.  For example, a report for November 1999 must be produced between November 1st and November 30th; a Snapshot Report run on December 1st may not be accurate for November.

Knowledge Requirements

Familiarity with Access is needed to enter data, move among fields, print reports, make back-ups, etc.  An intermediate knowledge of Access is needed to make routine changes to fields, menus, etc.  Expertise in Access is required to make major changes such as altering reports or queries, producing new reports, etc. 

Access to the CMS may be controlled by the database administrator, who should also make or approve all changes to the system.


Finally, for those drug courts which receive funding from the Drug Courts Program Office, U.S. Department of Justice, the CMS contains a built-in query system which produces case statistics (ex., number of males and females currently enrolled; number of admissions, graduations, terminations, withdrawals, and deaths; number of arrests and convictions for drug and non-drug crimes following graduation or termination) required for the DCPO’s annual survey.

The following sections will guide you through installing and using your CMS:

Getting Started
5

Loading, personalizing, and securing your CMS.

Entering and Viewing Client Data
6

Using the data entry forms, navigating among forms and cases, and entering data.

Creating and Printing Reports
8

How to create and print built-in reports and queries.

Customizing the CMS
11

Changing or adding to drop-down menus, adding new 

fields or pages to a form, creating and altering subforms.



Appendix A:  Field Definitions. Form by form, a list of field names, 



description, and location.

Appendix B:  Intake, Case Management, and Follow-up Forms.

Expertise needed to use the CMS. Every person using the CMS, whether entering data, simply viewing case records, or printing reports, should have a rudimentary knowledge of Microsoft Access, the database program underlying the CMS. All the standard Access functions, such as deleting records, using filters, and finding records, work in the CMS, and incorrectly using Access may lead to problems with the Drug Court CMS 2000.

We assume that a particular person in your court (the court's database administrator, drug court coordinator, etc.) will be in charge of the CMS.  This database administrator controls access to the CMS through passwords and/or the designation of workgroups which limit user access to specific information and protect the structure of the database.  Simple changes, such adding a choice to a drop-down menu or adding an information field to a form, are relatively easy to make and instructions for doing so have been included in this guide.  Please note, however, that changes made in fields related to the built-in reports may result in these reports being inaccurate.  These fields are listed on page 13.

Expertise in Access is needed to customize the built-in reporting functions, generate new or different reports, incorporate new queries, or produce caseload graphics.  Instructions for these types of advanced programming are beyond the scope of this guide, but may be found in a detailed Access manual.

“Dear Drug Court Coordinator.” The first decisions that need to be made before beginning to use the CMS concern how the database will be used, how data will be entered, and what modifications, if any, should be made to the CMS. For example, your court may want to use the entire CMS and enter information in “real-time,” as intakes are performed, contacts are made with participants, etc., using the entire CMS. Or you may want to use pieces of the CMS, leaving out particular sections (case notes, for example), and enter only needed data on a weekly basis. It is highly likely that customizing drop-down menus and specific fields will be needed to fit your drug court’s population and procedures. One person, or a few experienced staff, should enter a few cases and test the CMS vis-à-vis the court’s case management and information needs.

Once these initial decisions are made, we recommend that one person – the court’s database administrator, drug court coordinator, or other designated person (if your drug court is very small, these may all be the same one person, you) – be charged with the responsibility for maintaining the CMS’ security, customizing the CMS as desired, and training and monitoring all staff using the CMS. This person should be familiar with Access 97 and the CMS, and make all modifications (or as many as possible) before data are entered. All users not familiar with Access 97 or your court’s case files and procedures will need initial training followed by close supervision and monitoring until it is clear that correct information is being entered appropriately and accurately. Periodic verifications are recommended to ensure the quality of data entry.

Security and networking. There are two methods used in Access to protect a database: (1) set a single password for opening the database, or (2) establish user-level security, which limits access to different parts of the database to different users. Setting a single password is the simplest method; it requires each CMS user to type in the same password to open the database. Lost passwords cannot be recovered, so the password should be recorded in a secure place.  The user-level security method, although a bit more time consuming to establish, can be used to prevent users from accidentally damaging the structure of the database.  More information on these methods may be found on the Access Help Menu by typing in “secure a database.”

The CMS opens in a secure mode, with the database window hidden and menus partially hidden.  Changes to the basic structure and design are relatively easy to make, however, and the ability to do so should be limited to the database administrator or other designated staff.

The Drug Court CMS 2000 is intended for use within the drug court itself, and is not designed to link to, or electronically exchange information with, other agencies such as treatment programs and probation departments.  However, if you have multiple computers networked within the drug court office, more than one person may use the CMS at the same time.  The user-level security method allows you to assign passwords to different users and limit their access or the ability to enter or change data.  Unless you have experience with the maintenance of a multi-user environment, you may want to seek professional assistance in installing the CMS on a network. There are specific decisions to be made prior to the installation regarding user access, editing data, and editing database objects. 

Backups. As with any database or computer file, you should back up the CMS often to avoid the loss of information due to computer or power failures. Backups are made using standard software (e.g., Windows Explorer, My Computer, MS-DOS copy command, etc.) to copy the CMS database to the medium of your choice.  The CMS may be saved in compacted or compressed form to save space. Compact your database frequently, especially after making changes to the structure or entering and deleting data.  If the database file exceeds the size of a floppy disk, you must use Microsoft Backup or backup software to copy the file onto more than one disk. While data are saved automatically as they are entered, we cannot stress the need for frequent backups enough.  Please backup your CMS at least daily.

If you need assistance. Assistance in installing the CMS on your computer, using Access, and making changes to the CMS must be obtained from your court’s computer department. If you have specific questions regarding the use of the CMS, please contact Kristin Guertin at kguertin@redshift.com.


Getting Started

Loading the CMS.  The Drug Court CMS 2000 is an application built on Access 97, and thus cannot be installed by "Adding software" or running a program through Windows. Please note that the CMS cannot be read or used directly from the CD. The CMS is fully functional only after it is copied onto your hard drive and after you remove the check mark from “Read only” in the Properties dialog box (as described in step eight below). To begin, copy the CMS database from the CD to your computer:

1. Insert the CMS CD.

2. Open Windows Explorer.

3. Double-click on your CD-ROM drive letter.

4. Highlight (click once) the folder titled Drug Court CMS 2000, right click the mouse, and choose Copy.

5. Highlight the c:/ drive (or a folder you choose within the c:/ drive), right click the mouse, and choose Paste.

6. In your c:/ drive, open the copy of the Drug Court CMS 2000 folder. There are four items in the folder: the Drug Court CMS 2000 (an Access database), the CMS Manual (a Word document), Appendix A: CMS Field Definitions (a Word Document), and Appendix B: CMS Data Entry Forms (a Word document).

7. Highlight the words Drug Court CMS 2000, right click on the mouse, and choose Properties.

8. In the Properties dialog box remove the check mark from “Read-only” and click Apply.  

9. Click OK. Repeat this process for any Word document you wish to alter. 

10. Open the CMS you copied into the c:/ drive by clicking on it twice. If the CMS does not open, repeat steps 2 –9.

11. Remove the CMS CD.



Alternatively, you may simply click and drag the CMS from your CD-ROM drive to your hard drive, in the same way you may move word processing or spreadsheet files from one directory or drive to another.

The main menu.  Upon opening the Drug Court CMS 2000, the main menu appears, displaying eight options.  The first three options take you to the data entry forms (the Intake Form, Case Management Form, and Follow-up Form).  The next four options take you to the Lists of Participants, Case Summary Reports, Snapshot Reports, and Drug Court Program Office (DCPO) Reporting.  The last option closes the database.  Note that the menu titles appear at the top left corner of the screen.

Personalizing your CMS.  You will want to change the current name of the database, “JRC Drug Court, Pacific Grove, CA” (found on the upper left of the opening menu), to the name and location of your drug court. Instructions for personalizing your CMS are included in the section of this manual titled Customizing the CMS: For Administrator Use Only.


Entering and Viewing Data

Using the forms.  The first three buttons on the main menu are linked to the three forms used to input and view information on all drug court participants.  When you select Intake or Case Management from the main menu, a screen displays what appears to be a stack of manila file folders (referred to as pages of a form). The tabs of these pages are in full view. By selecting a tab, the information displayed on that page comes to the front of the screen.  Within each form, there are embedded subforms that record multiple data for one participant, such as all treatment services (type, agency, address, etc.) received prior to drug court.

The tabs -- or pages -- on the Intake Form are labeled:  General, Children, Health, Mental Health, Drug History, Treatment History, Criminal History, and Assessment Results.  The Case Management Form tabs are Drug Court, Court Date, Treatment, Contacts and Notes, Outcome.

The Follow-up Form records multiple interviews, for one participant, at specified intervals after the participant leaves drug court. Embedded within the Follow-up Form is an Arrests subform; this subform can record multiple arrests reported to the interviewer on one interview date. The Intake and Case Management Forms also contain embedded subforms that can record multiple data, on one topic, for one participant. 

Navigation.  Moving among all three forms, without closing the forms and returning to the main menu, is simple.  Located at the top right corner of each form are buttons bearing the names of the other two forms.  For example, located at the top right corner of the Intake Form are two buttons with the names Case Management and Follow-up.  If you are in the Intake Form of John Smith and click the Case Management button, you will be taken to the Case Management Form of John Smith.  Note:  Once you enter an individual intake, case management, or follow-up form, the CMS will "filter" the records, so you will only see that individual's information.  To see other records, you must turn off the filter.  For example, in order to stay in Case Management but view records other than those of Mr. Smith, you must de-select the Filter button on the toolbar. Close each form by clicking on the box labeled "close" in the upper right corner of the screen to view the main menu.

To move among all case records, you may click through the record numbers at the bottom left of each screen.  This is not terribly efficient, as cases are in the order in which they were entered (unless you re-sort the database, putting cases in alphabetical order by participants' last name, for example, and saving the results).  You may find any record by placing the cursor on the CaseID or Last Name field, clicking the binoculars on the toolbar, typing in the case number or last name you are looking for in the box titled Find What.  In the same way, you may find specific contents of any field (say the city of Boise), by placing the cursor in that field (in this case, City), clicking the binoculars, and typing in Boise. 

To sort CMS records quickly by last name (or first name), place the cursor in the field labeled Last Name on the Intake Form and press the button labeled A=>Z, or the button labeled Z=>A, on the toolbar.

Entering data. To enter data into the CMS simply place the cursor in a field and type in information. The Intake Form is designed so that the user may tab through from the first field on the form to the last field on the form, going through each page one at a time. To tab out of a subform to the next field or page, press Ctl + Tab. You will encounter a number of fields with built-in answers on drop-down menus. Use these built-in answers whenever possible to ensure accurate reporting. If the built-in answers are not adequate for your needs you can either (1) type a different answer into the field, or (2) change the built-in answers (see Customizing the CMS). 

Follow these steps to enter a new record into the database:

1. Choose Intake Form from the main menu.

2. Click the New Record button on the toolbar if you need a blank data entry form.

3. Type in the participant’s case number (assigned by your drug court) in the Case ID field on the Intake Form. Important: this field must be filled in for the system to operate properly.

4. Bypass the Name fields immediately following the Case ID field, and place the cursor in the field labeled First Name. The information typed into the First Name and Last Name fields is automatically copied to the Name fields on the top of the Intake form.

5. Continue to tab through the Intake form and enter information.

When you begin to record information on the Case Management Form, you will notice that three fields appear more than once: current phase, current status, and discharge date. When you enter data (or make changes to the data) in one of these fields, the same data appears in each copy of the field.  Definitions of all fields, in the order they appear on each form of the CMS, begin on page 18.

You may specify a default value for any field. If your drug court is in California, for example, you may want "CA" to automatically appear in the State field of all addresses, unless you enter a different state.  Setting a default value for a field has no impact on existing data. Instructions on setting a default value may be found in the section of this manual titled Customizing the CMS: For Administrator Use Only.

Creating and Printing Reports

Note:  If you do not have a printer driver installed on your computer, you will be unable to view reports.

Lists of Participants
A list of participants, including full names, addresses, all five telephone numbers, and date of intake, may be printed either in alphabetical order or in chronological order by the admission date. The user may choose to produce the report on current participants (those admitted to drug court and currently active (i.e., participants who have not been discharged as of the time the report is run)), or for all participants ever admitted to drug court.

To produce a list of participants:

1. On the main menu, click the button labeled Lists of Participants.

2. On the Lists of Participants menu, select one of the four reporting options.

3. If you selected a report on current participants, the list of participants will appear on screen and can be printed. If you selected a report on all participants, a prompt will appear. The prompt is used to determine a beginning date for the report (the end date is the date you run the report). Therefore, if you type in 1/99 at the prompt, the report will include all participants who were admitted to drug court on or after January 1, 1999. After typing in a date, click OK.

4. With the report on screen, choose either Print Report or Return to Menu. 

Case Summary Reports
As on the next page, these reports present an individual’s current status in drug court, and an overview of their progress as measured by their involvement in 12-step programs, urinalysis results, points earned, and sanctions applied.

To produce a Case Summary Report for one participant:

1. On the main menu, click the button labeled Case Summary Reports.

2. On the Case Summary Reports Menu, click Case Summary for one participant.

3. A prompt will appear asking for a case number. Type in the case number of the person whose report you want to produce. Click OK.

4. You will see a print preview of the report. Click the Print button on the toolbar to print the report.

Individual reports may also be prepared for all participants who have been admitted to the drug court and not yet been discharged.  To produce Case Summary Reports for all participants:

1. On the main menu, click the button labeled Case Summary Reports.

2. On the Case Summary Reports Menu, click the button labeled Case Summaries for all current participants.

3. You will see a print preview of the report. Click the Print button on the toolbar to print the report.

12-Step Progress, Urinalysis Results and Payment Summaries
Individual reports covering a participant's attendance at 12-step meetings, urinalysis results, and payments to date may be printed.  They all have a format similar to the 12-Step summary progress report which is depicted on the following page.

Individual summary reports may be viewed and printed by:

1. On the main menu, click the button labeled Case Summary Reports.

2. Click the appropriate button on the Case Summary Reports Menu.

3. A prompt will appear asking for a case number. Type in the case number of the person whose report you want to produce. Click OK.

4. You will see a print preview of the report. Click the Print button on the toolbar to print the report.

Snapshot Reports

Snapshot Reports allow the user to determine, on any given day, the status of current cases (active, in custody, bench warrant status, etc.), the number of participants who left the program that month, the total current caseload (broken down by phases), the number of participants currently in treatment (broken down by treatment area), and the number of new referrals for that month. 

The data on Status of Referrals (assessments completed, cases admitted, etc.) reflects all new referrals made from the first day to the last day of the month for which the report is run. Likewise, the data on Left Program (death, graduated, etc.) reflects all participants who left the program from the first day to the last day of the month for which the report is run.  All other data reflect the status of cases on the day the report is produced.

To produce a Snapshot Report:

1. On the main menu, click the button labeled Snapshot Report for Current Month.

2. Click the appropriate button (corresponding to the current month) on the Snapshot Reports Menu.

3. At the prompt, type in the current month and year (ex: Jan 99 or 1/99).

4. You will see a print preview of the report. Click either Print Report and click OK or Return to the Menu (without printing).

DCPO Reporting
This form is designed to produce information requested on DCPO surveys.  Clicking on the field of a case statistic needed takes you to screens requesting the time period (1/99 to 6/99, for example), followed by the CMS producing the correct figure.

To produce the form:

1. On the main menu, click on the button labeled Drug Court Program Office (DCPO) Reporting.

2. Press any button on the DCPO reporting form, and you will be prompted for a beginning date and an ending date. Type in the beginning date and click OK. Type in the ending date and click OK. 

3. The database produces a statistic according to the dates you have supplied.

4. Click on the lower “x” in the upper right corner to return to the DCPO reporting form.

Customizing the CMS:  For Administrator Use Only

Note:  In this section, instructions are given for overriding the built-in security in order to make changes to the database. For this reason, you may want to make this section of the manual unavailable to users.


To make changes, you must first override the built in security.  To do this, open the database while holding down the Shift key.  The CMS will open in Design View, displaying the database window.  Compact the database after making changes by clicking on Tools => Database Utilities => Compact Database.

Below, five types of changes for customizing your CMS are described step-by-step. They provide the user with relatively simple ways to tailor the information system to meet local needs.  The five types of customization are:

1. Personalizing the CMS. Place the name and location of your drug court on the main menu.

2. Defining a default value for a field. Use default values to ensure accurate reporting and speed up the data entry process. An example of using a default value would be to automatically assign the value “CA” (for California) to the state field on the Intake Form for every new record.

3. Creating a new or modifying an existing “combo box,” or drop-down menu. Examples of combo boxes or drop-down menus are the choices under Ethnicity on the Intake form and those in the Arrest fields, which may be modified to fit your local community.

4. Adding new fields or pages to a form. Fields are discrete pieces of information, such as the participant’s First Name, Middle Initial, and Last name.  Pages refer to a whole screen, such as the Drug History and Criminal History portions of the intake form.

5. Creating a new or modifying an existing subform. Subforms refer to forms within forms that enable you to enter multiple pieces of like information -- such as information on each child of the participant or all physicians the participant has seen in recent years.

Before reading the customization instructions, please review the key definitions and instructions below and the caution not to alter fields that feed into the built-in report and DCPO queries. 

Key Definitions and Instructions
Forms vs. subforms.  A form is used for entering information into a database, and to view data already entered. A subform is a form within a form. A user can work with a form or subform in both Form View and Design View.

 Form View vs. Design View. Users "view" forms, subforms, and reports in either Form View or Design View.  Form View is used to enter data or to view previously entered data. Design View is used only to make changes to tables, forms, queries and reports. To open a form in Design View: click the Forms tab on the database window, highlight the name of the form, and click the button labeled Design on the right side of the database window. To change between Form View and Design View while a form is open on the screen: select Form View or Design View from the drop-down menu on the View button on the toolbar.

Text boxes and fields.  A text box is a box that holds a label for a field on a form. A field is a box into which the user types information. On the Intake Form, for example, a text box holds the label First Name. Following the First Name text box is a field that holds the participant’s first name. 

To size and position a text box or field:

1. Go to Design View of the form containing the boxes.

2. Select (highlight) the box by clicking on it once.

3. To move the entire box, place the cursor on the largest black box appearing in the upper right corner of the text/field box. When the cursor turns into a hand, click and drag the box.

4. To size the box, place the cursor over one of the small, black boxes appearing in the middle of each side of the text/field box, and drag the edges out or in.

Data types.  Every field in a table must be assigned a data type. The following definitions of data types are taken from the Access Help Menu:

Data types

Definition
Text


Text or combinations of text and numbers, such as addresses. Also numbers that do not require calculations, such as phone numbers, part numbers, or postal codes. Holds up to 255 characters.

Memo


Lengthy text and numbers, such as notes or descriptions. Hold up to 64,000 characters.

Number


Numeric data to be used for mathematical calculations, except calculations involving money (use Currency type). Set the FieldSize property to define the specific Number type. 1,2,4, or 8 bytes.

Date/Time

Dates and times. 8 bytes.

Currency

Currency values. Use the Currency data type to prevent rounding off during calculations. Accurate to 15 digits to the left of the decimal point and 4 digits to the right. 8 bytes.

AutoNumber

Unique sequential (incrementing by 1) or random numbers automatically inserted when a record is added. 4 bytes.

Yes/No


Fields that will contain only one of two values, such as Yes/No, True/False, On/Off.

More information on these and other, more advanced, data types may be found by clicking on the Office Assistant button on the toolbar and typing in “data type.”

Database window.  The Database Window automatically appears on screen when you open the CMS while holding down the Shift key. If you “lose” this window while working in the non-secure mode, press F11 to bring it to the front of the screen. The Database window provides the user with options for viewing and manipulating database objects, the underlying structures and design of the CMS. Database objects include tables, queries, forms, reports, macros and modules. Do not close the database window unless you are finished with the CMS. Closing the database window closes the entire program.

CAUTION: If you plan to use the built-in reports and queries, the following fields must be kept up-to-date, and not altered or deleted during customization of the database without appropriately altering the reports as well.  If the data are not complete and current, report results will not be accurate.  In addition, changing the drop-down menu responses of some fields will disable the DCPO reporting queries (the buttons on the DCPO reporting page) associated with that field.  Do not alter these drop-down menu responses if you plan to use the DCPO reporting queries.  These fields are marked below under Special Considerations as DCPO compliant.

Form


Field




Special Considerations
Intake


Ethnicity



Built-in responses are DCPO compliant. 


Age



Built-in responses are DCPO compliant.


Gender



Built-in responses are DCPO compliant.






Referral date


Tied to reports.


Date of assessment

Tied to reports.


Admitted to drug court (Y/N)
Tied to reports.


If rejected, why?


Tied to reports.

Case


Current Phase


Tied to reports.

Management 
Current Status


Built-in responses are DCPO compliant.


Discharge Date (from DC)

Tied to reports.


Information on Court Date page
Tied to reports.


Arrest charges since last court date
Built-in responses are DCPO compliant.


Current 12-step requirement
Tied to reports.


Type of treatment


Tied to reports.


Treatment admission date

Tied to reports.


Treatment discharge date

Tied to reports.


Employed at graduation (Y/N)
Tied to reports.


Outcomes during drug court
Tied to reports.

Follow-up

Interview date


Tied to reports.


Months after discharge

Built-in responses are DCPO compliant






Self-reported abstinence

Tied to reports.


Arrest date


Tied to reports.


Charges



Built-in responses are DCPO compliant

Personalize your CMS  

To change the current name of the database to the name of your drug court:

1. Click on the Forms tab of the Database Window. Highlight the word Switchboard on the Forms tab and click the Design button.

2. In Design View of the Switchboard, place cursor inside the box that says JRC Drug Court and backspace over these words.

3. Type in the name of your drug court.

4. Place cursor inside box that says Pacific Grove, CA and backspace over these words.

5. Type in your own city and state.

6. Click Save button on toolbar.

7. Close the Switchboard by clicking on the lower “x” in the upper-right corner of the screen.

Any changes you make to the main menu usually appear after you close and re-open the database.

Define a Default Value for a Field

To set a default value for a field:

1. Using the section of this manual titled Field Definitions, determine which table holds the field for which you want to define a default value.

2. On the Database Window, click on the tab labeled Tables.

3. Highlight (click once) on the table, and click the button labeled Design on the right side of the screen.

4. In the upper portion of the Design View of the table, click on the name of the field.

5. In the lower portion of the Design View of the table, click the Default Value property box and type in the default value (such as California or CA).

6. Click Save on the toolbar.

7. Close the form by clicking on the lower “x” in the upper-right corner of the screen.

Create or Modify a Combo Box (drop-down menu)
To create a combo box (or drop-down menu list of responses), first:

1. Go to Design View of the form. On the Forms tab of the database window, highlight the name of the form and click the button labeled Design.

2. Click once on the field, right click the mouse, and select Change To => Combo Box.

To create or modify the drop-down list of selections:

3. Double-click on the field to open its Properties box.

4. Under the Data tab, select Value List from the drop-down menu under Row Source Type.

5. Under Row Source on the Data tab type in the drop-down options in the following format: “option A”; “option B”; “option C”. For example: “married”; “separated”; “divorced”; “widowed”, etc.

6. Close the Properties box.

7. Click Save on the toolbar.

8. Go back to Form View to test the new combo box. 

Adding New Fields or Pages to a Form
Add a new field to a form.  First, create the new field in the main table:

1. In the database window, click the tab labeled Tables.

2. Highlight the table named Main to add a field to the Intake or Case Management Forms; highlight the table name Followup to add a field to the Follow Up Form.

3. Click the button labeled Design.

4. Scroll down to the end of the list of field names.

5. Type in a name, without spaces, for your new field (you may later alter the name on the form).

6. Enter data type (See chart on page 12 to determine data type).

7. Click Save on the toolbar.

8. Close table.

Then, place the new field on the form:

9. Click on Forms tab of database window.

10. Highlight the name of the form on which you will place the new field: Intake, Case Management, or Follow-up Inserted Form.

11. Click the button labeled Design.

12. Click Field List button on toolbar.

13. Scroll down to the bottom of field list.

14. Click on the new field, drag it onto the form, and release the button to place it on the form.

15. Close the Field List box.

16. Label the field by clicking inside the text box.

17. Position and size the new field.

18. Click save button on toolbar.

19. Go to form view to review the changes.


Create a new page.
1. Go to Design View of the form:  In the Database Window, highlight the name of the form and click the button labeled Design.

2. Right click the mouse and choose Insert Page.

Name the page:

3. Double-click on the tab to see the Properties box for that page.

4. Under the All tab in the Properties box, type in a name under Name. Type it again under Caption.

5. Close Properties box.

Change the order of pages as they appear on the form:

6. Right click on page and select Page Order form the drop-down menu that appears.

7. Follow the instructions to change the page order for that form.

8. Click OK, click Save on the toolbar, and go back to Form View.

Creating or Altering Subforms
The following directions guide the user through the process of creating a subform that is used for inputting and viewing multiple entries on one topic for one participant.  For example, a subform is used to record and view information on all children of each participant.


Create a subform. First, create a new table for the subform:  

1. Determine the names of your new fields for the subform.

2. In database window, click on Tables tab.

3. Click New button.

4. In New Table box, select Design View and click OK.

5. Type “ClientID” in Field name, and choose “Number” from drop-down list in Data Type. 

6. Type “(TableName)ID” in Field name on the next line. For example, if your table pertains to the participant’s spouse you would type in “SpouseID.” Choose “Auto Number” from drop-down list in Data Type. 

7. With the cursor still in the box containing the words Auto Number, click the Primary Key button on the toolbar. A picture of a key should appear to the left of the field name.

8. Type in new field names and data types.

9. Click the Save button on the toolbar.

10. In Save As box, type in a Table Name and Click OK.

11. Close table.

To connect the new table to the main table:

12. With the database window on screen, click the Relationships button on the toolbar.

13. Click Show Table button on toolbar.

14. Find and highlight name of your new table in Show Table box.

15. Click Add button.

16. Close Show Table box.

17. Click on ClientID in box labeled main, drag to the box with the label of your new table, and drop on ClientID. A Relationships dialogue box should appear.

18. In Relationships box, click on join type.

19. Click option 3 and click OK.

20. In Relationships box, check Enforce Referential Integrity.

21. In the Relationships box at the bottom, relationship type should be One-To-Many.

22. Click Create button.

23. Click Save button on toolbar.

24. Close Relationships window.

Create the new subform:

26. In the Database Window, highlight the form on which you want to place the new subform.

27. Click the button labeled Design.

28. Click the Toolbox button on the toolbar.

29. Select (click on) Control Wizards button in the Toolbox.

30. Click on Subform/Subreport button on toolbox bar.

31. Click on form to place the subform.

32. On the first screen of the Subform/Subreport Wizard, choose Table/Query and click Next.

33. On the second screen of the Subform/Subreport Wizard, select the name of your new table from the drop-down list of tables. Move all fields listed under Available Fields to Selected Fields and click Next.

34. On the third screen of the Subform/Subreport Wizard, choose Define my own. Choose ClientID for Form/report fields, choose ClientID for Subform/subreport fields, and click Next.

35. On the fourth screen of the Subform/Subreport Wizard, type in a name for the new subform. (Hint: use the word “subform” in the name for easier identification later).

36. Click Finish.

Modify the new subform:

37. Double click on subform (appears as a white box) to open it in Design View.

38. Choose Datasheet View from drop-down menu of View button on toolbar.

39. Click on ClientID to highlight column.

40. Choose Format => Hide column.

41. Repeat steps 39 and 40 for other “ID” field.

42. Click on a field name (any) to highlight column.

43. Choose Format => Font. Set Font at Arial, Font Style at Regular, and Size at 8.

44. Choose Design View from drop-down menu of view button on toolbar.

45. To change the name of a column heading, highlight (click on) the field under the Detail section, right click the mouse, and choose Properties.

46. In the Properties box under All, type in the column heading as you would like it to appear under the row titled Name.

47. Repeat steps 45 and 46 to change other column headings in the subform.

48. Save and close subform.

49. Go to Form View of form that contains your new subform.

50. Change column size by placing cursor on line between column titles, clicking and dragging.

Alter an existing subform. To remove an existing field, make changes to test, or alter a drop-down menu on a subform:

1. Go to Design View of the form that contains the subform.

2. Double-click on the subform placeholder (the blank box on the form) to open the subform.



To remove a field:  Select (click on) a field, and choose Edit => Delete.


To change text:  Select (click on) a text box, click inside the box, and alter the text.


To alter a drop-down menu:  Follow instructions on page 14.

3. Click Save and close. Go back to Form View of the form on which the subform is located.

Permanently delete the full record of a participant. 


As a precaution, general users cannot permanently delete participants from the CMS without taking the time and effort to prepare the system to accept deletions:

1. Open the database while holding down the Shift key to override the built-in security.

2. Choose Tools, then Relationships.

3. In the Relationships window, double click on the black line connecting Main and Children. Check the box titled Cascade Delete Related Records. Click OK.  Repeat this process for every other relationship (boxes connected by black lines).

4. Click Save.

To delete the full record of a participant:

1. Place the cursor in the Case ID field (on the Intake Form) of the participant whose record you want to delete.

2. Click on the Delete Record button on the toolbar, or choose Edit => Delete Record from the drop-down menu.

3. Microsoft Access will ask if you are sure you want to delete the record of this participant.  Click Yes to permanently delete the record; click No to restore and save the record.

4. Compact the database.  Tools => Database Utilities => Compact Database.


After the deletions have been made, you will need to return to the Relationships window to uncheck all the boxes labeled Cascade Delete Related Records.  This step is necessary only if you decide to maintain this extra level of security.
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